Ford Escape Automobiles Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello:

When the weather gets warm my 05 Escape Hybrid develops an interesting but dangerous problem. This is the second summer. The first summer I had it towed to a Ford dealer who checked it, charged me $100 +/- and found nothing. This summer I took it to my local mechanic, coolant in radiator is fine as well as in resivoir. It is his belief that the codes that would show up are somehow blocked by Ford as nothing came up on his computer.

Here's the deal: Drive along fine then suddenly engine temp message and avatar come on. Pull over let it sit. OK to drive. Sometime that's it. Sometime it comes back again. Check out coolant tank; everything is as it should be. However sometimes the pull over quick or u will die avatar comes on and u better pull over or the vehicle shuts itself off. Pretty scary anywhere u don't have a decent shoulder to pull over to.

So far my research reveals that the most likely problem is: motor electrical cooling pump needs to be replaced. Does anybody have any experience with this?

Let me say that I love this car. The 05 was the premier of this line of vehicles and Ford did a great job with this SUV. I have over 100,000 miles. It has been very reliable. Recently the mpg has dropped but I can probably live with that. Shutting itself off, I can't live with or I may not survive.

Thanks!
 

·
Registered
Joined
·
758 Posts
Your vehicle is overheating. It is either the Motor Coolant Electronic Pump (MCEP) about $180.00 and/or the blend door issue. There is a thread on the blend door issue for DIY section on this site. The MCEP sits under the radiator and can also be a DIY with the usual mechanical tools. Your mileage is sufferring from this issue.
 
1 - 2 of 2 Posts
Top