Ford Escape Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings. I'm a newbie here, and to Escapes, so please bear with me!

My daughter's 06 Escape has a turn signal issue. To be specific, the left side flashes rapidly, and the right side just illuminates without flashing. All of the bulbs are in working order, and I plan to replace them anyway. I had the same problem in my old Jeep XJ, and a flasher unit cured it, but I was told by my mechanic, that it would likely be the multi function switch in the steering column. Upon a little research here, I see that it could be other, more complicated, things as well.

I realize that there are no quick answers, but any advice is appreciated. Thanks!
 

·
Registered
Joined
·
436 Posts
Your right, it could be the multi function switch, or some wiring issue caused by corrosion. A good electrical auto tech can find the issue.
 

·
Premium Member
Joined
·
3,418 Posts
I think there is no flasher in the circuit. I think the GEM does the flashing, perhaps using relays. I would check all relays, and make sure the bulbs light properly when checked out of the socket. One check you can run is the emergency flasher, which uses the same bulbs and wires, but I think bypasses the multi-function switch. If everything works as advertised using the emergency flasher, it pretty much limits problems to the switch and the wiring immediate. There was a problem with F-150 wires that were too short, and when the tilt mechanism was used, would stretch(try) the wire until there was finally a break in the wiring. Solution was to jumper in some lengths of wire to replace the split(or another harness).
tom
 
1 - 3 of 3 Posts
Top