Ford Escape Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello,

This is my first post here. I purchased my wife a 2005 escape xls 4 cylinder 2wd yesterday. The vehicle has 80,000 miles and is relatively good shape. I have 3 problems that I believe 2 are related. 1) The Cruise Control (CC) is not turning on. 2) The brake pedal is making a noise as you are releasing it after depressing it. 3) The passenger side hi beam light is not functioning or burned out. We are going on a trip to Walt Disney World and would like to take care of this on Friday before we leave.

I believe that the CC oand brake pedal noise are related. I believe there is a stop light switch or brake pedal position switch that is mounted at the brake pedal. Is this correct ? Is it fairly easy to swap out ? or is there something else that could be causing the problems ?

The light bulb should be fairly easy to swap out. That looks a lot easier than taking the whole unit out that is for sure.

Thanks for any tips you can provide !!!

Patrick
 

·
Registered
Joined
·
3,080 Posts
The brake pedal switch is easily replaced.
As for the CC I would first look into the fuse and relay before proceeding.I will be surprised if the two are related.
Good luck and let us know with your progress.
 

·
Registered
Joined
·
370 Posts
I recently had this issue with my 2005 Escape, here's what happened. I started hearing a hissing noise after releasing my brake pedal and turning the car off. It was infrequent at first but became more and more frequent, looked this problem up and come to the conclusion it was the brake booster. Took it to the shop to get it replaced and the noise went away. After leaving the shop and getting on the highway I tried to engage my cruise control and it would not engage. I did more research on the issue and realized that sometimes when the brake booster is fixed the pedal is not in contact with the switch that controls the brake and cruise control (pedal had a loose feeling).

The noise could be the brake booster, and the lack of cruise control could be due to a loose brake pedal (lot of play). Try taping 2 quarters on the pedal arm to engage the cruise control switch to see if that will solve the problem. Follow the brake pedal arm up and you will see the switches. Hope this helps.
 
1 - 3 of 3 Posts
Top