Ford Escape Automobiles Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a weird problem in my wife's Escape. Only with the engine running, when you turn on the headlights on low beam there is a buzzing noise that sounds like its coming from passenger side of the dashboard. No difference if in the on or auto positions on the light switch. No noise if using high beam or just fog lights. All the lights work like there supposed to, none of them are out. Had the car over 2yrs, this noise started just a couple of days ago. Any ideas? Thanks
 

·
Registered
Joined
·
1,734 Posts
Hmmmm have you checked fuse panel inside cab and perhaps fuse box under hood ( I know u said passenger side)
 

·
Registered
Joined
·
293 Posts
dash8avionic said:
I have a weird problem in my wife's Escape. Only with the engine running, when you turn on the headlights on low beam there is a buzzing noise that sounds like its coming from passenger side of the dashboard. No difference if in the on or auto positions on the light switch. No noise if using high beam or just fog lights. All the lights work like there supposed to, none of them are out. Had the car over 2yrs, this noise started just a couple of days ago. Any ideas? Thanks
Sounds like the headlight relay may be going bad. I'm almost certain its on the passenger side. I know I hear a click on that side when my headlights turn on. Take it to the dealer if its still under warranty.
 

·
Premium Member
Joined
·
12,362 Posts
The low beams on a 2008 are actually controlled by high-side FETs (solid-state devices) inside the Smart Junction Box (inside the front of the center console). The low beams are also pulsed, and that could be the source of the buzzing. The only relays used for exterior lighting are for the parking lamps and fog lamps.

Are you using an aftermarket sound system and/or a plug-in MP3 player? The buzzing could actually be coming from the audio system picking up RFI from the pulsing.
 
1 - 4 of 4 Posts
Top