Ford Escape Automobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys, new here and could use a bit of help. I just replaced the speakers in my 2008 XLT and they sound great, but lack bass. I purchased a Boss 600 powered sub (needed something small). But, I have absolutely no clue how to even install this. What is the simplest way to install this sub? I have the factory HU and amp without navigation system.

Thanks for the help!
 

·
Registered
Joined
·
490 Posts
I'm guessing the Boss powered sub has some high-level (speaker) inputs? If so, tap into your front speaker wires, and run them to your sub. Then run the power and ground for your sub, and you might be set. Typically, most powered subs don't need a turn-on lead if you use the high-level inputs (don't know about Boss?). If your sub does not have speaker-level inputs, you'll still need to tap into your speaker wires, and buy a Line-ouput-converter (LOC). You can then run RCAs from the LOC to amp. With this set-up, you'll also need to rig a remote turn-on wire.

PS. I'd tap into the factory wires before they go into the amp.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Alright, I have just about everything to do the installation, including my LOC, and have found how to wire through the firewall but I am stuck. How do I wire the 12v? I don't want the amp on when my car is off, what is the easiest way to wire this? Also, for the ground, I am wiring the amp in the trunk and I have the cargo package...could I wire the ground to one of the screws that holds down the cargo container underneath the carpet? Or is there an easier place?
 

·
Registered
Joined
·
267 Posts
noodle654 said:
I don't want the amp on when my car is off, what is the easiest way to wire this? Also, for the ground, I am wiring the amp in the trunk and I have the cargo package...could I wire the ground to one of the screws that holds down the cargo container underneath the carpet? Or is there an easier place?
I'm not sure how it is with factory head units but on my kenwood there is a light blue wire in the harness and it's a remote turn on switch (specifically for the sub amp)
As long as there is a current in the wire the amp will be powered so if you can't find the remote turn on maybe you can find another low voltage wire to use (with the sound system)

And as for the ground, thats exactly where I put my ground and it works perfectly-- I put my own wiring kit in for my sub, and I also have a Boss amp
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
How do I install my LOC? Where do I do it. I have yet to find a single guide on how to do this exactly. Do I use my rear speaker (as in take apart the panel and such) or slide in the wire behind my factory hu. I am extremely confused.
 

·
Registered
Joined
·
1,058 Posts
1 - 9 of 9 Posts
Top