Ford Escape Automobiles Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi All,

I apologize if this has been covered in a previous post, I did some sleuthing and I didn't find anyone with similar problems, but I may have missed something. I have a 2017 Ford Escape Titanium (2.0L, AWD, 110Km's). Recently it has developed the following issues:

-stalls or idles very low/runs rough when coming to a stop. It essentially idles poorly (~500rpm, engine shaking) when in drive or reverse.
-given enough cycles of this, the computer will throw a P061b code. This code never persists, no CEL. It only shows up as a pending code on some drive cycles.
-engine is smooth on the highway, shifts well, has lots of power. No driveability issues, except when coming to/from a complete stop.

Things I have tried:
-Cleaned the MAP sensor (The one on the intake, can't reach the one on the intercooler)
-removed and cleaned the intake manifold (it was oily, but otherwise ok)
-checked for vacuum leaks (there were none that I could find)
-decarboned the intake valves (using a soak of seafoam and a little bit of scraping)
-cleaned the throttle body (seafoam, cloth)
-checked the air filter (it's nearly new, in great shape).
-replaced the plugs (it was due anyways, seems slightly more peppy afterwards).
-removed the tape on part of the wiring harness to inspect for chaffing (to address TSB regarding chaffed wires)

The only thing I have achieved by doing all of the above is that the engine doesn't seem to stall out as much, it just idles really low and shakes. It feels like a transmission issue, but I have no transmission related codes. Does this sound like a torque converter to anyone? Or the torque converter solenoid? If so, is there any additional diagnosis I can do to confirm it's the TCC or TCC Solenoid?

Thanks, Ivan
 
1 - 1 of 1 Posts
Top