Ford Escape Automobiles Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Went on a little trip to the Oregon coast the past few days and the ABS light came on twice. I was low the first time in brake fluid so I topped off but do not think it had anything to do with it but the light stayed off for a day but just came back on. I shut down and cranked it up again and it has stayed off since. Loose connection somewhere? Any one have any ideas?
Many thanks, Mike
:bill:
 

·
Premium Member
Joined
·
4,977 Posts
Next time you have the wheels off, check the ABS sensor - that's the little black plastic sensor on the hub that reads the tone ring, which looks like a big gear. Those seem to get cracked in the wintertime from debris getting stuck on the tone ring.
 

·
Registered
Joined
·
1,455 Posts
Are you experiencing any brake problems?

If so, pull the ABS fuse and see if the problems persist. If they do, it ain't an ABS issue. If the problems stop it's almost certainly the sensor rings like Squishy said. (Well. He did mention the rings! :) )

Biggest problem with replacing the sensor rings is the cost. I had this done for both my front sensor rings. They're not available separately from the driveshaft, so they replace the whole lot! pricey! :worry:
 

·
Super Moderator
Joined
·
4,736 Posts
That happend to me on my 04 Escape. The cruise contol module was messed up and had to be replaced.
 

·
Premium Member
Joined
·
12,362 Posts
That's the only problem my sister and bro-in-law had on their 2001 Escape. It was the right sensor and not the ring, from what I remember.
 

·
Registered
Joined
·
1,283 Posts
i had an abs light come on, and it ended up being my sensors covered in crap and ice. i cleaned it up and cleared the code and it went away.
 

·
Premium Member
Joined
·
3,648 Posts
I had this same problem a while ago. I was on my way to Ft. Wayne, IN to goto a Rascal Flatts concert and my ABS light was blinking, I believe 3x consecutively, then nothing, then block 3x again...JP told me it was my speed sensor. But the darn thing hasn't blinked since -\/-
 

·
Registered
Joined
·
13,629 Posts
My ABS light came on about two months ago. I suppose its a safety feature, because the cruise control was disabled. Anyway the service tech replaced the ABS sensor under warranty. He then reprogrammed the settings with a laptop. :)
 
1 - 10 of 10 Posts
Top