Ford Escape Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I just got my 2009 Escape Limited V6 4WD and just noticed that at speeds about 30-45ish when I take a good turn or hit a bump the ambient lights flicker or turn off for a while then turn back on. So far it seems completely random. I can't get it to happen every time I hit a bump or make a turn but it does happen. I had my brother in the passenger seat stare at it for a while and he saw it with his eyes. I thought I was going crazy. I will be taking her back to Ford to have it looked at but wanted to see if anyone else has seen or experienced this. Definitely doesn't seem like a normal thing that should happen. Any help would be appreciated!
 

·
Registered
Joined
·
2 Posts
I have a 2008 Mariner, my lights do the same thing, only when my head lights are on. I have returned it to ford service center 4 different times and they have no clue what it is, or what is causing it. They keep telling me to bring it back when it does it again since it won't do it for them. Good luck getting it fixed.
 

·
Premium Member
Joined
·
1,256 Posts
While under warranty you should push the issue... It is obviously a loose connection. They can trace the wire harness and components involved and find the problem they just don't want to spend the time.

Fight for your right... to have ambient lights :doh:

JP you got a diagram?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top