Ford Escape Automobiles Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
So here is my story. I bought a CPO 09 Escape 4x4 V6 on February 20th 2010 with 18900 miles. In mid March the service engine light came on. Off to the dealer I went. The dealer ordered the part and three weeks later my car was fixed. Though all was well and then my car started stalling at red lights and idling rough. Drove it for a few more days and then the service engine light came on again. Dropped it off at the dealer on Monday May 10th and was told the car needed to have the transmission rebuilt and I could pick my car up Thursday. I called Thursday to make sure I could pick the car up and they told me the part did not come in yet and the car was not ready. Awesome communication. The car was ready this past tuesday and I though all was well for the last day. Then my service engine light comes on again today requiring another trip to the dealer.

Legally is there anything I can do?? I traded in my old car, because I wanted something more economical and family orientated since I will be getting married soon. This car is turning into a total nightmare now and I fear in the future I'm going to have to dump a ton of cash into it when ill have more important things to worry about like houses and children.

To say the least i'm totally frustrated and to make matters worse a rock demolished my windshield today. Icing on the cake.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top