Ford Escape Automobiles Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
After driving 30min to a hospital parking for an hour then starting my 2010 escape with 9200 miles on it the check engine light came on again for a very minor exhaust leak according to the code reader. Was wondering if this has happened to anybody else
 

·
Registered
Joined
·
3,080 Posts
dcr61288 said:
After driving 30min to a hospital parking for an hour then starting my 2010 escape with 9200 miles on it the check engine light came on again for a very minor exhaust leak according to the code reader. Was wondering if this has happened to anybody else
When you say the "light came on again", do you remember exactly when that happenned before and what you did about it?
Have you verified the exhaust leak yourself?
Some electronically loaded environments may interfere with the PCM of the car.It is not common but it happens.
Please let us know of the outcome.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
The last time it came on was about 3 weeks ago when I started it up to go from my work to home which is only a 5 min drive. When I got home I brought the code up on the obd II code reader I have and just cleared the code thinking it might just be something minor and hopefully wouldn't happen again.

I did check for leaks and didn't hear any, had some suspicions that it might be somthing with the capless gas system knowing that some times if the cap isn't tightened on normal cars that it can show up.

I ended up taking it back to the dealer and what they had to do was pull the cap less gas tank and reseat it. they said it fixed it and i haven't had the light come back since.
 

·
Registered
Joined
·
3,080 Posts
Thank you for posting the results.I hope it is fixed for good.Many happy miles.
 

·
Premium Member
Joined
·
13,543 Posts
Like SUVord said, hopefully that fixes it for good. Thanks for posting your findings. It's always apprciated by the community.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
I guess I managed to put the proper amount of miles to get the cel to come back on because when I was leaving work this afternoon it came back on when it started. My dad has my reader so I'll have to wait to see if its the same code or not but I'm sure it will be.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 ·
an update on the cel
Last Wednesday I went back to the dealership to get it looked at again. After roughly 2 hrs of waiting the office manager came out to talk to me and told me that somewhere along the line the system sensed fuel vapor which caused the code. Since the last time the reseated the cap-less fuel system they called ford engineers who told them a few things to tighten that should fix it. I've driven about 250 miles since then and haven't had it come back yet.
 

·
Registered
Joined
·
1,734 Posts
Hope it is fixed, can you let me knw what the code that was thrown out was?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #9 ·
I don't remember the exact number but it showed up as: exhaust leak (very slight[or something like that])
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
dcr61288 said:
I don't remember the exact number but it showed up as: exhaust leak (very slight[or something like that])
I actually found a picture of it on my phone today the number is P0456 says evaporative emission system leak detected (very small leak)
 

·
Registered
Joined
·
1,734 Posts
Well that code would pertain to the fuel vapor managment. So the common thing in 08 and below would be loose gas cap. But in your (09 and up) would be something to do with the the whole capless gas cap and everyhting that falls behind that. I am sure the dealership will find something. So let us know.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #12 ·
oskerb said:
Well that code would pertain to the fuel vapor managment.
the second time i had gone to the dealership they told me that sometime it sensed fuel vapor also he informed me that due to what they did the first time not fixing it they consulted ford engineers who told them to tighten a few things and it has been fixed since then

oskerb said:
So the common thing in 08 and below would be loose gas cap. But in your (09 and up) would be something to do with the the whole capless gas cap and everyhting that falls behind that. I am sure the dealership will find something. So let us know.
the first time i had gone to the dealership they pulled the capless gas system and re-seated it
 

·
Registered
Joined
·
1,734 Posts
Good I hope its fixed. I would like to know what they "tightened".
 

·
Registered
Joined
·
1,316 Posts
dcr61288 said:
yea me too
FYI, your (evaporative) emissions system and your exhaust system are two entirely different things. The emissions system makes sure that no gasoline vapors are able to vent to the atmosphere, and instead are routed to the engine for burning. The exhaust system makes sure all of the nasty byproducts of combustion get expelled safely out the back end of your vehicle.

I'm curious to know what you can reseat on a capless fuel system. My guess is that they tightened down the flap that is in the fuel filler neck that seals the tank from the open air.
 
1 - 15 of 15 Posts
Top