Ford Escape Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
Two weeks in and loving the Escape more and more.

I find myself regretting not getting more options - my practical wife talked me out of the convenience package. While in retrospect I suppose some of it isn't really that necessary for us (like MyKey; our first baby won't be driving for another 16 years, so I'll be sure to get it on our 2026 Escape!), I wish I had the compass, outside temperature display and message center (I'll work on that one in another thread).

While it seems that it is impossible to add outside temperature display to the truck after it has left the factory (details here http://www.escape-city.com/viewtopic.php?f=13&t=1931&st=0&sk=t&sd=a), I couldn't find anything on adding the compass functionality.

Has anybody done this or have any advice?
 

·
Registered
Joined
·
1,734 Posts
sorry dude, big question with no definite answer cause no one has actualy done it.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
Thanks for the reply. I'll keep trying. Going to check out a couple of salvage yards this week and see if I can't find some components.
 

·
Premium Member
Joined
·
12,362 Posts
The compass is part of the auto-dimming mirror and the instrument cluster, which must have the message center and message center switches. So adding the compass would also add the message center functionality, but only with those three new sets of parts and their harnesses.

Outside temperature requires the climate control module from an Escape that was equipped with the sensor from the factory, as well as the display interface module. When I asked someone from Ford a few years ago about this, they said that simply adding the sensor would enable the display.

It's really too bad that the software/firmware of the various modules isn't programmed so that simply adding the sensor enables whatever feature is disabled when the sensor isn't there!
 

·
Registered
Joined
·
1 Posts
I know this is an old topic, but I figured it was a good place to ask vs. starting a whole new one. My wife and I recently bought an '08 Mariner with a salvage title. There were a lot of little things to be fixed and we were in the process of taking care of those when she pointed out the ugly mass of bulging wires connected to something clipped behind the mirror. There was a bunch of electrical tape and cord wrap and the mirror doesn't have any display or sensors on it, so we cut the wire off.

It didn't take long to realize that we killed the in-dash compass function, so I fished the wire(s) out of the trash and removed the excess (there are 7-8 wires coming from the ceiling and taped into the bundle we cut off but only a 4-pin connector). See the last picture on this post to see what I am talking about. We don't have any wires going forward into the actual mirror, just the small connector on the compass unit right by the part that connects to the windshield. The wires are blue w/ orange, yellow w/ green, black w/ grey, and blue.

I bought some tiny heat shrink butt splices and tried to re-attach the wires but something didn't work so I cut them off and now I don't have enough slack to try again. I don't know if the display will show only dashes until it is re-calibrated (I only read about that later) or how to know when I've got it working, but I tried just twisting the wires together and it still didn't work. :wall:

What do you recommend I do to re-attach this and get the compass function back? I'm thinking I might have to remove at least part of the headliner to access the wires or other end of the connector. I am somewhat concerned that I might have loosened the wires on this end of the adapter or something and don't know how to test/verify if it's working. Can I order a whole new full-length wire/connector? I don't even know where it attaches on the other end! Any help would be appreciated!
 
1 - 5 of 5 Posts
Top