Ford Escape Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I had a clunking noise in the car that occured regularly. I took it in and they told me that the engine mount was bad. It is a mount filled with oil apparently and the oil was gone.

I had it replaced and the noise is gone but now because they replaced it with a solid mount, you can feel the engine vibration.

Is this normal?

Can I still buy the original oil filled mounts?

Thanks for any input
Ron
 

·
Registered
Joined
·
294 Posts
Yes the mounts are oil filled like a tiny shock absorber (which they are) and they do have a tendency to leak/go bad after a while, they are much more expensive than the solid mounts and u wont feel the engine vibration so much with them in.

here is one: http://www.partsgeek.com/gbproducts/WC/ ... oogle+Base

You can also get the same thing at the ford dealer, on some things i dont personally go aftermarket but it depends on what it is.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the reply. I took it back to the shop that put it in.

First he said the vibration was because the idle was to low. I said, how can that be, all you did was change the mount? Besides that isn't the idle computer controlled? He finally took it in the shop and they found that the new mount (which actually is a oil filled one) was leaking.

They will replace it and we will see what happens.

Thanks again
Ron
 

·
Registered
Joined
·
294 Posts
sounds like the guy was bluffing u a little...
When the idle is low it will vibrate more but usually its normal for the idle to rev up to 2k RPM on initial startup and drop slowly back down to 800-950RPM which is normal for the V6. It souldnt vibrate noticeably when it drops back down to its regular idle. A non oil-filled motor mount will magnify the vibration.
The idle is for the most part computer controlled like everything else is on the Escape but a very low idle isnt normal and isnt good either and a number of things could cause that.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Well, they changed the mount to another new one (from a different manufacturer they say) and the car feels normal again.

Thanks for all the verification guys, it's appreciated.

Ron
 
1 - 5 of 5 Posts
Top