Ford Escape Automobiles Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

This is my first post on the forum I have a 2003 Mazda Tribute with the 3.0 V6. It has 120,000 miles on it but has been sitting for the past few months. It's now time to fix it back up!

The problem is it sputters and does not accelerate right after a good rain storm. My friend told me it is probably the coil pack so I sprayed them with some glass cleaner and sure enough the car started to sputter. I plan to replace them along with the plugs. I read on another forum about global automotive who sells coil packs on eBay, for our cars it's like 75$ for the full set of 6 where as the dealer charges like 84$ each! They have posative reviews on other forums, anyone here try them???? What about the wires that run to the coil packs? Could they be bad too?

While I have the entire intakemanifold off to get to the rear plugs, I also plan to change the EGR valve, the Pcv valve and replace the intake gaskets. Is there any good DIY's for this?

What else should I be looking to do? I'm going to hit the vaccum lines with some silicone spray because they are starting to look a little brittle.

Thanks Everyone!!

Tom
 

·
Premium Member
Joined
·
13,543 Posts
I don't have any advice, I just wanted to say I was thinking about asking the same question. I was also hoping jpark could post the steps regarding the removal of the manifold...

Good luck fixing your issue...
 

·
Registered
Joined
·
1,734 Posts
Your on the right track. I am not sure what it might be but go with the PCV first, then if not work your way up
 
1 - 3 of 3 Posts
Top