Ford Escape Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
2003 Ford Escape LXT
Joined
·
3 Posts
Discussion Starter · #1 ·
2003 ford escape xlt 3,0 eng. 4 wheel drive
okay here the problem:
I Installed new bank 1 and bank 2 catalytic coverters and new egr valve because the old one blew a hole in it,
after installation I started truck and a loud screeching whine sound when accelerating in park and.gets worse at higher rpms But I can barely hear it at idle.
so I put new serpentine.belt on it, noise still there, Now the a/c compressor is new, as is the alternator, water pump, and idler pully.
power steering pump works fine, no noises from it. Oh, I also removed the belt and started the engine without it, noise still there.
any ideas on what else that can cause the noise?
 

·
Registered
Joined
·
105 Posts
How's the vehicle running otherwise? Does it seem to have the power that it should? Why did you replace the converters?
I replaced Bank 2 converter 1 and after that I had a screeching noise found out that part of the converter had come apart and gotten stuck in front of the converter at the middle of the vehicle, restricting the exhaust.

Sent from my moto g power using Tapatalk
 

·
Registered
2003 Ford Escape LXT
Joined
·
3 Posts
Discussion Starter · #3 ·
My escape would run, but not good at all, no power, engine surge at stop lights. Transmission would not change gears without letting off the gas. I changed the cats because the egr valve exploded from the back pressure. Had a 1" hole. And today I replaced the dpfe sensor found it to be broken too.
 

·
Registered
2003 Ford Escape LXT
Joined
·
3 Posts
Discussion Starter · #4 ·
Update on truck, today I loosened the exhaust flange in front of the 3rd cat and created an exhaust leak, started it up, reved the engine, It was loud but, I think the screeching stopped. The engine seemed to have a lot more power.
Hopefully that was the problem. Right now the cat is soaking in a solution to clean, if this works at least I will be able to drive it till the new cat gets here, and it comes FedEx so when I get it is a mystery
 

·
Registered
Joined
·
105 Posts
The screeching I had was back pressure and I did as you did to confirm.
The 3rd cat had a fine 'sand' and clumps of the bank 2 converter in front of it.
I pulled out what I could, vacuumed to try, but the 3rd was partial plugged.
Let us know how it turns out.

Sent from my moto g power using Tapatalk
 
1 - 5 of 5 Posts
Top