Ford Escape Automobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
328 Posts
Discussion Starter · #1 ·
hello,

i had my front pads and rotors replaced a few months back and recently they have picked up a really bad squeek at stop lights, and anytime braking under 10km/h. they still work great though.. my mechanic told me that its because "they are hard pads" and theres 3 things i could do...

1) replace the brakes again with better pads and rotors even though i just did them.
2) said he can machine the rotors and sand the pads and it will stop it but we all know thats not a very permanent fix.
3) live with it till the brakes are done..

anyone got any tips for me? squeeking is really annoying me and my passengers...
 

·
Registered
Joined
·
1,734 Posts
All you need is new pads, you get for what you pay for. No ned for new rotors What made you get new rotors???
 

·
Premium Member
Joined
·
4,977 Posts
Were the pad backing plates lubricated with silicone grease or "Disc Brake Quiet"?
 

·
Registered
Joined
·
328 Posts
Discussion Starter · #4 ·
i dont know much about what the guy did. unfortunatly i didnt think to watch him.
i know they are probably low quality brakes. also on the backing plates of the pads there is a material pad. which my mechanic says is suposed to stop squeekes but its practically falling out...
 

·
Premium Member
Joined
·
4,977 Posts
Those would be shims. If they are falling off, I would just remove them and apply a coating of Disc Brake Quiet to the back. You can get a can of it at NAPA.

Also, did you burnish the pads? 10 firm stops from 50 km/h to 10 km/h followed by 1 km of driving (no stopping) and 5 more firm stops from 80 km/h to 10 km/h. Obviously should be done somewhere with no traffic - I do it on country roads at 3 am. Make sure not to come to a complete stop in the middle of the process, or you will create a hot spot on the rotor.
 

·
Registered
Joined
·
142 Posts
My 05 Escape had squeaky brakes too not long after I changed the pads. I read an article and got out a torque wrench and re-torqued all the lugnuts to the proper torque (98 ft-lbs) and the squeaking stopped within a week or so.
 
1 - 6 of 6 Posts
Top