Ford Escape Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter · #1 ·
I am not sure what it is called and I am sure it is a fuse but was unable to determine in the manual which one it was. Ok I have two power points in my car along with the one you can plug something into. The one right across from it on the left works fine. The one that does not work is the one that is up on the radio. It shows 10 am, 12 volt I think. Does anyone know why it does not work and do you think it could be a fuse? If it is a fuse, which one could it be.

It is circled in red

 

·
Registered
Joined
·
1,734 Posts
Check the fuse. Do you have the manual? There it would have the answer of what fuse is what.Have you tested the power port in any way?
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #3 ·
oskerb said:
Check the fuse. Do you have the manual? There it would have the answer of what fuse is what.Have you tested the power port in any way?
Yes i have tested it. Plugged in ipod charger and did not worked. Plugged charger in other cigarette plug and it worked fine. Looked in manual but not able to locate. The name on the cpver of the hole is not listed.
 

·
Registered
Joined
·
1,659 Posts
davids2005 said:
oskerb said:
Check the fuse. Do you have the manual? There it would have the answer of what fuse is what.Have you tested the power port in any way?
Yes i have tested it. Plugged in ipod charger and did not worked. Plugged charger in other cigarette plug and it worked fine. Looked in manual but not able to locate. The name on the cpver of the hole is not listed.
Look at #12 listed as power port.
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #5 ·
wptski said:
davids2005 said:
oskerb said:
Check the fuse. Do you have the manual? There it would have the answer of what fuse is what.Have you tested the power port in any way?
Yes i have tested it. Plugged in ipod charger and did not worked. Plugged charger in other cigarette plug and it worked fine. Looked in manual but not able to locate. The name on the cpver of the hole is not listed.
Look at #12 listed as power port.
Thanks will try that. If that is the power port, what would the fuse be for the other one? I assume it is combine fuse with the power plug that I have as well. I also assume this fuse is on the inside?
 

·
Registered
Joined
·
322 Posts
Not sure on your year, but I blew a fuse on one of my power ports on one of my Fords (I forget which now) by trying to run too much amps thru it. The other power port still worked fine. I had to get the manual out, and find all the fuses to replace, this one wound up being under th hood; but sorry do not recall what the book said, power point, or something else.

Is this a new problem, or just occoured?
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #7 ·
08HybridOK said:
Not sure on your year, but I blew a fuse on one of my power ports on one of my Fords (I forget which now) by trying to run too much amps thru it. The other power port still worked fine. I had to get the manual out, and find all the fuses to replace, this one wound up being under th hood; but sorry do not recall what the book said, power point, or something else.

Is this a new problem, or just occoured?
Well I have never used it before as no need to. The other day I bought a car charger for the ipod so wanted to try it out.
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #8 ·
I found it. #12 was not the power point but #24 was the cigarette lighter. I pulled that one out and it was blown. So that should fix the problem hopefully.
 
1 - 8 of 8 Posts
Top