Ford Escape Automobiles Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey there. I'm a new member here and I've got a 2008 Tribute. I just replaced the front rotors and put new pads in and while everything worked out fine and the Tribute drives like new and brakes very nicely the abs likes to kick in upon slow acceleration. I can't be too sure if it actually is the abs but when I accelerate the brake pedal shudders a bit. Also sometimes when I make a turn the tcs comes on and slows me down. Has anyone else experienced this before or can anyone shed any light on this problem?

p.s. brakes are still in their break-in or bedding period.
 

·
Registered
Joined
·
1,734 Posts
You may want to check the 2 things the TONE RING and the TONE RING SENSOR. These are usually the culprit.
 

·
Registered
Joined
·
3,080 Posts
oskerb said:
You may want to check the 2 things the TONE RING and the TONE RING SENSOR. These are usually the culprit.
...and you can jack up the front end and with the gear lever at neutral rotate slowly one wheel after the other and see if you can sense any rubbing off the rotors.If you do sense some kind of rubbing, take out the caliber and the pads and place them back on following the specified torque.With your hands push the rotor in and make sure it stays straight before you put the wheel back on.I hope that may be the problem and not the tone ring and sensor which are known to also cause problems of that kind.Good luck and keep us posted but not before you send a six pack to Iraq.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for the replies. I'll definitely take the wheels off and have another look. Hmm, I remember the rotor was seized onto the hub so I had to hit it a few times and there were rust pieces flying everywhere. It may have gotten in contact with the tone ring or the sensor? Also I didn't have a torque stick on me at the time so I just tightened the caliper down with a breaker bar. What is the torque specs on the caliper bolt?
 

·
Registered
Joined
·
3,080 Posts
First things first:Did you send some nice brew to Iraq?I know you did, so you may proceed.

1/Brake caliper torque for the two torx bolts on pre 2005 models is 35 Nm.
2/Use a brakes and clutch cleaner liberally.
3/Make sure you get rid of all the rust that accumulates inside the caliper piston where the inner pad hinges in.A small wire brush works wonders.
4/Check that the brake fluid in the reservoir has not reached the cap after you put the new pads.Siphon out any excess fluid so that the level is at the idicated max indication.
5/Make sure the rotor wabbles freely after you take off the caliper.
6/Unscrew the tone ring sensor and clean well all surrounding area with brake cleaner.Before screwing back the sensor in position apply dielectric grease where the screw is going to seat.

PS.:The brew will be appreciated by our ever so helpfull and great member, Oskerb, who is stationed in Iraq.
 
1 - 5 of 5 Posts
Top