Ford Escape Automobiles Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,283 Posts
Discussion Starter · #1 ·
so yesterday i was driving down the highway at about 110km/hr when my battery light came on, i immediately shut of my heat and radio, and allowed only my DRL's to be on. after about 5-10min the light went out, any ideas? i have an AVR at work so i can test my alternator and battery, but i was wondering if anyone has had a similar thing with theirs to save me some diagnostic time.

and front struts, i got a clunky one, so im gonna change both, preferred brands??? and did you change your springs as well as your struts? i was thinking of getting a set of KYB, unless anyone of you guys who have changed out just the the hell of it wanted to sell me your old ones cheap enough.

This escape must be a lemon, cause its only got 138000km and its starting to nickle and dime me. rear wiper motor doesnt work, no rear defrost. and teh drivers seat is warn out lol. if i had about 4000 bucks i could get rid of the negative equity in it and send it on its way.
 

·
Registered
Joined
·
21 Posts
On our work Escape when the battery light came on usually they replaced the alternator. I've heard the internal regulator likes to go bad. Is there a green light on the battery? How about the terminals corrosion wise? On the struts have you replace your end links? They tend to go bad and clunk on bumps. Mine does it also.. the boots are about to fall off the end links on mine so I know it's the cause. The rear wipe/defrost sounds like corrosion to me look at the fuse box under the hood.. on some 01's the wiring harness had to replaced when this happen. Majority of the time the owner was able to clean it up and get it work. You've probably had other vehicles but I don't know your experiences but eventually every car will nickel and dime for a couple months but once everything is fixed usually have no problems for years.. well exception would be GM I guess. Even my wife corolla beloved toyota nickel and dime us for a year.
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter · #3 ·
i have only replaced the rotors and pads on my wife cobalt. and she got it the day after i got my escape lol. the rear defrost needs to be soldered. thanks for the info on struts. i guess i will borrow the AVR from teh shop and test teh alternator and the batter. i hope its the battery and not the alternator lol, then i can just put in a jel pack and be done with it.
 

·
Registered
Joined
·
13,629 Posts
The last time my escape battery warning light came on, i thought it was going to be the alternator. Actually would have preferred it being the alternator. But alas it was not to be. The escape was sent to an auto- electrician. He performed a few tests and diagnosed the escape cpu had malfunctioned. Basically the car computer was stuffed. The nickname for this device down under is the ' black box '.

So henceforth the car central processing unit was replaced under warranty. They checked the alternator but it was not being erratic.
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter · #5 ·
so i went to my shop today. only to find, that i need a rear output seal for the tcase/PTO, a passenger side front axle output seal, a seal for the tensioner, and my alternator has a HUGE piece of the casing broke off. and i still have not found the part that goes clunk cause my back was too sore so i gave up for the day. today is a depressing day for me to be an escape owner. the battery did score really low on the AVR it passed but barely. and the alternator is outputting no problem.
 

·
Premium Member
Joined
·
3,648 Posts
I would replace the battery before the bitter cold gets here...otherwise you may be running into some problems!
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter · #8 ·
i have a red top at a buddies house, i just have to go and pick i up. im surprised my alternator still works though, i should take a pic of the housing piece i have. its huge. the local junk yard has one that they will give me for 85 bucks, so im gonna swap it out, and then buy a new housing and brushes and rebuild mine as a back up. the scrap yard one does have a 1 year warranty, but its the only one they said they have lol
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter · #9 ·
its ben a while since ive been able to hang out here!!. update on my blue beast. i swapped out the alternator. and i can see why the dealer charges 4 hrs. what a pain. i will never do that on an escape again lol. and im going to order lower control arms, and link kits (ina few minutes after i find the post with the link in it lol). while i was there, i also changed the serpentine belt., that was the easy part.
 
1 - 9 of 9 Posts
Top