Ford Escape Automobiles Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter · #1 ·
This should be a good question for jp or others that are in the know about Ford's electrical system setup/design. I mentioned it briefly before, but figured I'd mention this again, as I don't think what I have is normal.

As you know, I have an 06 Limited, and something that has been bothering me as of late, is that my Tailights are ALWAYS on, as long as the vehicle is running. Only time they are off, is if my parking break is engaged. I'm thinking this isn't normal, as other Escapes/Tribby's I've seen, only have the front lights running in DRL if their lights are shut off. Mine are on even if the switch is off. Now, I know that on a safety standpoint, this is probably a good thing, but I think that the tail/park lights should only be on when the parking light setting or full headlights are switched on.

Am I crazy? LOL

L8tz
 

·
Registered
Joined
·
1,283 Posts
do you have auto on lights?
 

·
Registered
Joined
·
333 Posts
Discussion Starter · #3 ·
Yes I do, but I almost never use that setting...I like to manually turn my lights on and off. I don't think that the rear lights being on is hurting anything at all, but i'm just curious as to why they are ALWAYS on, even if the light switch on the stalk is off...
 

·
Premium Member
Joined
·
12,362 Posts
Sorry that I missed this one the first time around!

Are the license plate and parking lamps on at the same time?
 

·
Registered
Joined
·
333 Posts
Discussion Starter · #5 ·
Umm, I'll have to doublecheck and get back to you, but as far as I remember, the tailights are on with the front DRL, no front marker lights, no license plate lights...
 

·
Premium Member
Joined
·
12,362 Posts
The '05 to '07 models do have a separate feed to the tail lamps and parking lamps, but the tail lamps include the license plate lamps, so those should be on as well.

With the DRLs on, pull the F3 (15A) fuse in the fuse box. If the tail lamps don't go out, you probably have a short somewhere, or maybe a programming problem with the SJB.
 
1 - 6 of 6 Posts
Top