Ford Escape Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
imputtin afermarket rims on, ive got a 08 with the low tire presure monitoring thingy, im just curious if i need it as in will it light up low tire presure with out it cause if i dont need it i wont wasted 200 bucks on getin them installed
 

·
Registered
Joined
·
3,091 Posts
Your going to need it if you want the light to stay off. I got my rims from tire rack with the sensor already for $1592. They were mounted balanced, they installed the sensors.They also give you the lug nuts, and the sensors were recognize by the computer.
 

·
Registered
Joined
·
1,734 Posts
Is the tire shop doing the wheels for you charging you this? By now I bet you already have new wheels on. But there isnt much for the tire shop to do other than unband the adjustable band reband to the new rim. If you havent yet bought them I would haggle with them.

2008_xltduratec said:
imputtin afermarket rims on, ive got a 08 with the low tire presure monitoring thingy, im just curious if i need it as in will it light up low tire presure with out it cause if i dont need it i wont wasted 200 bucks on getin them installed
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
1,734 Posts
Shouldnt be hassle for you, if the tire shop wants a sale they should do it for free or a minimum fee. But $200 is a lot. The only way I see that this would be sensible if you use the OEM for like "beater tires" or winter tires. In any case more power to you and dont forget to pst pics :beer:

2008_xltduratec said:
havent got the tires on yet but im goin in on friday, i just didnt want the hassle of popin the tires of the 17's im goin to go to a canadian tire and see if they can put aftermarket sensors on ( http://www.canadiantire.ca/AST/browse/4 ... iewDetails )
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #6 ·
the plan was to use the stock as like you said winter/ long trip tires,as mud terrains will wear out fatser
 

·
Registered
Joined
·
35 Posts
I just had the my snows installed on my '09 and didn't pay extra $200 for TMPS. The light on the dash comes on now, which is easily covered with a little peel away sticky - but the warning "tire pressure monitor fault" that comes up every time I start the vehicle is a PITA..I hit reset to clear it - but on restarting it's back. Any way to disable that?
 

·
Registered
Joined
·
467 Posts
bought four tpms on ebay for 99$ last year and they were recognized instantly when installed my winter tire.

i think 99 $ is not too much to avoid all the lights and warning messages hehe

EDIT: Just checked again on ebay and nothing under 200$ this year :shrug:
damn, got a set of 4 last year, 99$ shipped and they were real ford with logo on it.
i realize that i got a real deal :yahoo:
 
1 - 8 of 8 Posts
Top