Ford Escape Automobiles Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hey Everyone!
New problem from the Escape - there's a ticking noise coming from under the passenger side dash. Only when any of the vent system is turned on, A/C - heat - reg air blowing - anything. Goes away when all is turned off. Just a leaf/stick in there, or is it something more? Doesn't sound very organic though - almost sounds more mechanical, but that could just be because of where it's coming from?
Thanks for any and all help!
 

·
Premium Member
Joined
·
12,182 Posts
Doesn't that just tick you off?

Probably something mechanical, but a small leaf (or something else) might have made it's way to the fan and the a/c heat system by dropping down the defroster vent.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Thanks David,
Yeah - I talked my brother last night (he's a mechanic) and he said to him it sounds like the blower motor. Could be that a leaf or nut or something got in there, or the rotating plastic piece cracked that's inside it, or might just need a new blower motor - either way, he said it's not too bad and nothing to really worry about - more annoying that anything else. Which he is very corrrect on :)
 

·
Registered
Joined
·
82 Posts
McScape said:
Thanks David,
Yeah - I talked my brother last night (he's a mechanic) and he said to him it sounds like the blower motor. Could be that a leaf or nut or something got in there, or the rotating plastic piece cracked that's inside it, or might just need a new blower motor - either way, he said it's not too bad and nothing to really worry about - more annoying that anything else. Which he is very corrrect on :)
could be just the motor, and doesnt really need a new one unless it annoys you that bad. Sounds like the same ticking I have with my F150, although luckily it doesnt happen or just isnt noticeable at the lowest setting....just the next one up and higher. Anyhow, I finally tore into everything at one point near the beginning thinking maybe I got a leaf of something down in there. Everything was clear, nothing cracked, etc, all A-ok. It's been that way for 6yrs now, still doing it, hasnt gotten any better nor worse, the motor's performance hasnt changed at all either, just plain ole same as day 1 still.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
Yeah, if it didn't get better, I was definitely going to fix it. Even on the lowest setting and the radio on, you could still hear it. BUT - that being said - it fixed itself. Must have been something stuck in there. We were camping up in Canada and all of a sudden it got louder, so, of course being very annoyed I cranked up the air to full blast and it suddenly stopped and hasn't ticked since. Must have had something stuck! :)
 

·
Premium Member
Joined
·
12,182 Posts
Not to get your hopes up too much, but it could come back again. :yes: If it's something loose, it's a for sure "comeback". If it's organic, or piece of something that came off, then it's anyone's guess. I think it'll be back sooner than later... :shrug:
 

·
Registered
Joined
·
48 Posts
Ok I too just encountered this problem, however mine is a little bit different. This "ticking" only really appears above 50MPH and seems centered in my dash area. It sometimes goes away if I shut off my heating/ac blower unit so I don't know if this is the culprit. :cuss:

Any thoughts on this one as well?? Vehicle is 06 Escape XLT

Thanks
 
1 - 12 of 12 Posts
Top