2005-2012 Throttle Issue

Official Ford recalls and TSBs!

Re: 2005-2012 Throttle Issue

Postby MadMax - August 3rd, 2016, 9:50 am

Blista wrote:I am having a throttle/lag issue intermittently that seemed like the transmission, I'm sure this is the issue. The Mariner has 103,000 and I found a "field service action" attached to my VIN on the Ford site. 13N03. Does this mean they will fix it even though it never threw a light on???

Just wondered.


No, it means they extended the warranty to 150K/10 years should it go bad you're covered
Image
2017 Escape Titanium 2.0T AWD, Sport Appearance Package, Panoramic Sunroof
User avatar
MadMax
Super Moderator
 
Posts: 14781
E-C LEVEL 20
Joined: February 29th, 2008, 7:11 pm
Location: Wisconsin

Remove Advertisements

Escape-City.com
Advertisement
 

Re: 2005-2012 Throttle Issue

Postby Blista - August 13th, 2016, 9:04 am

They just threw a new one on, no charge. I spelled out the exact symptoms of throttle drop/surge for 5 second intervals under cold conditions. I guess they did not want to screw with it. They opened it up, and it was loaded up, put the new one on in 15 minutes. ;) happy Ford customer here !
Blista
 
Posts: 8
E-C ROOKIE
WELCOME TO E-C!
Joined: July 21st, 2016, 7:07 pm

Re: 2005-2012 Throttle Issue

Postby MadMax - August 13th, 2016, 11:33 am

Blista wrote:They just threw a new one on, no charge. I spelled out the exact symptoms of throttle drop/surge for 5 second intervals under cold conditions. I guess they did not want to screw with it. They opened it up, and it was loaded up, put the new one on in 15 minutes. ;) happy Ford customer here !


I'm glad it all worked out for you :thumb:
Image
2017 Escape Titanium 2.0T AWD, Sport Appearance Package, Panoramic Sunroof
User avatar
MadMax
Super Moderator
 
Posts: 14781
E-C LEVEL 20
Joined: February 29th, 2008, 7:11 pm
Location: Wisconsin

Re: 2005-2012 Throttle Issue

Postby K270 - June 26th, 2017, 2:13 am

I'm curious if anybody ever had their engine light come on because of this throttle body issue. My engine light came on today while on my way to work. It stayed on after I left work. I'm going to seek someone out who has a one of the code reading machines to see whats going on. I haven't had any issues with drops in acceleration. I currently have just over 104,000 miles on my vehicle. I didn't even think about doing a vehicle health report until a minute or two ago. Will do that on the way out tomorrow and check my e-mail right away.
Image

40% Tint Front Windows
Cravenspeed Stubby Antenna
Billet Grille upper and lower bumper
Ford Made Bug Shield
Ford Made Sun Roof Wind Deflector
Escape Decals bought off e-bay
User avatar
K270
 
Posts: 307
E-C LEVEL 3
Joined: December 5th, 2012, 4:42 am
Location: San Mateo, CA.
My vehicle: 2012 Ford Escape XLT
My vehicle's name: Wile E Scape

Previous

Return to Recalls and TSBs

Who is online

Users browsing this forum: No registered users and 6 guests

cron