Throttle position sensor issue

Finally, a forum for E/M/T Hybrid owners? What a concept!

Throttle position sensor issue

Postby Flyboy - April 5th, 2021, 6:52 am

Hi there,
recently I got a engine light while driving on the cruise control. When the light comes up, CC is disengaged by the system and a lack of power is noticed. Putting it on the reader shows the P2135 fault. TP sensor invalid signals.

This is where it becomes kind of interesting.

The workshop manual does not mention a TP sensor for the hybrid engine. At the position where normally a TP sensor is installed on a 2.3l engine, nothing is present.

Does anybody know how this TP sensor fault story makes sense?? Is it located somewhere else? Why does the WSM not mention the sensor?

Thanks in advance

John

2008 Escape Gen 2
Sweet home Alabama
2008 Ford Escape Hybrid, green, bugshield, sidebars, hitch, foglight and mirror sidemarkers(EU req), bought dec'10
-replaced ignition lock module
-replaced AC Condenser
1984 mercedes Benz 380 SL
-fully restored by me
1999 Suzuki Hayabusa
- Yes, it's lonely at 200mph
User avatar
Flyboy
 
Posts: 38
E-C ROOKIE
WELCOME TO E-C!
Joined: August 5th, 2014, 7:39 am
Location: Netherlands
My nickname: Flyboy
My vehicle: 2008 Ford Escape Hybrid
My vehicle's name: Kiwi

Remove Advertisements

Escape-City.com
Advertisement
 

Re: Throttle position sensor issue

Postby Flyboy - April 5th, 2021, 10:05 am

Update:
actually found the TPS which is attached to the throttle body opposite of what a regelar 2.3L has and different in shape. Partnumber of the body is 5M6G-CC. Probably a part that comes with a complete throttle housing and not as a seperate part. Still weird that the WSM does not talk about a TPS for the Hybrid. Gonna try to clean it first to see if that helps.
Sweet home Alabama
2008 Ford Escape Hybrid, green, bugshield, sidebars, hitch, foglight and mirror sidemarkers(EU req), bought dec'10
-replaced ignition lock module
-replaced AC Condenser
1984 mercedes Benz 380 SL
-fully restored by me
1999 Suzuki Hayabusa
- Yes, it's lonely at 200mph
User avatar
Flyboy
 
Posts: 38
E-C ROOKIE
WELCOME TO E-C!
Joined: August 5th, 2014, 7:39 am
Location: Netherlands
My nickname: Flyboy
My vehicle: 2008 Ford Escape Hybrid
My vehicle's name: Kiwi

Re: Throttle position sensor issue

Postby bangster - April 5th, 2021, 10:29 am

Is the 2008 Hybrid "drive by wire"/"Electronic Throttle Body" or does it still have a physical mechanical throttle cable?
'17 SE, FWD 1.5T Magnetic Metallic
201A (halogen projectors, Sync 3, BLIS, SyncConnect, Reverse Sensing)
Nav (boo), Power Liftgate
bangster
 
Posts: 1041
E-C LEVEL 6
Congratulations on reaching 1,000 posts!
Joined: April 7th, 2017, 1:45 pm
Location: Tucson AZ
My vehicle: 2017 Escape SE FWD 1.5T 201A
My vehicle's name: magnetic


Return to Hybrid Green Zone

Who is online

Users browsing this forum: No registered users and 12 guests