Page 1 of 1

Hybrid acceleration issues

PostPosted: September 13th, 2020, 10:58 pm
by Aerostarnes97
Hi all,

I loved my 07 Hybrid until I started having issues with it. It started a year ago, happened once, then not again until 6 months later, when it became more frequent. The issue is that while accelerating, I lose rpms infrequently. The engine will accelerate fine until 4,000 rpms, and then it will feel like it’s stumbling and the rpms dip to 2,500 or so. I lose acceleration power, and the the rpms will climb back to 4,000 and all will be normal. The mechanic I took it to said it was something to do with the transmission/battery, but said it needed to go to the dealer. I ended up buy an ‘09 Escape, so I haven’t put time or money into it. It would be nice if I could figure what’s wrong to give a better idea to someone buying it from me, but I may or may not fix it depending on cost. Should I take it to the dealer? Or just sell it as is.... any ideas?

It has 135,000 miles, FYI.

Re: Hybrid acceleration issues

PostPosted: October 3rd, 2020, 12:16 am
by MAX_LT
Is this right after startup, or randomly with a warm engine?

I have noticed with my '05 that it is always grumpy for a minute or so after a cold start. If I try to drive right away it doesn't respond well to the gas pedal. I've also noticed that charge/draw needle on the dash shows the electric motor drawing current for that first minute, presumably meaning the electric motor is assisting the gas motor to idle.

-Max.

Re: Hybrid acceleration issues

PostPosted: October 4th, 2020, 8:54 pm
by Aerostarnes97
It’s always with a warm engine.... this is not a response issue per say, it is well after the acceleration sequence is in play. Usually 5-10 seconds into acceleration up a hill

Re: Hybrid acceleration issues

PostPosted: October 5th, 2020, 1:06 am
by Tembrant
Does the assist needle do anything wacky while that happens?

Re: Hybrid acceleration issues

PostPosted: October 8th, 2020, 1:35 am
by Aerostarnes97
you know, i haven’t watched it. It’s doesn’t happen enough times for me to know a pattern to predict it, and like i said in the post i don’t drive it any more...

Re: Hybrid acceleration issues

PostPosted: October 14th, 2020, 6:12 pm
by barrythedude
I would scan for codes before throwing parts at it. To me that sounds like a weak throttle body, but it could be anything from a coil breaking down to a bad spark plug, or cracked boots that sometimes arc. All things that are pretty easy to test tho.