2005 Ford Escape - Engine bucks only between 1500 - 2000 rpm

Got a problem? Want to find the solution? Check here!

2005 Ford Escape - Engine bucks only between 1500 - 2000 rpm

Postby Darkseid - February 18th, 2020, 5:29 pm

2005 Ford Escape XLT 3.0L V6 DOHC - starts and idles fine. Good power up to about 1500 rpm and then again above 2000 rpm. Problem does not exist outside of this range. Pressing the gas pedal is when the symptoms show up within that range. If I let go of the gas pedal and it is in that range it will not buck. No engine codes show up.

When it is bucking within that range occasionally the Theft light will come on with a notice of no power slightly but the car will keep going.

I have done the following to try to assess and fix the issue with no changes to the actual problem:

- Replaced Fuel Pump, Fuel Filter, ICV (Idle Control Value) and Gasket, EGR Value, Inner Manifold Gaskets, Spark Plugs, Coil-on-Plug Boots, TPS(Throttle Position Sensor), Air Filter and the PCV Valve

- Cleaned Throttle Body and MAF (Mass Airflow Sensor) with the proper cleaner, tried using different fuel octanes and fuel cleaners as well

Have used both a mechanic code reader/live data tool along with my own BlueDriver code reader but nothing is coming up out of the ordinary.

Another thing I have noticed is when I punch down on the gas pedal to the floor in order to gain quick speed I do feel some slight hesitation spurts where, in my opinion, feels like fuel is having issues getting through but you would think that some sort of code would show up.

I'm stumped at this point and instead of throwing more money towards additional parts and taking it back to the mechanic again (they were unable to find the issue the first time) I though I would try here.
Darkseid
 
Posts: 1
E-C ROOKIE
WELCOME TO E-C!
Joined: August 19th, 2012, 1:45 pm

Remove Advertisements

Escape-City.com
Advertisement
 

Re: 2005 Ford Escape - Engine bucks only between 1500 - 2000

Postby Charles - February 19th, 2020, 2:14 pm

I took the liberty of moving your topic to our Problems and Solutions forum to increase the likelihood of getting an answer to your issue. :yes:
ImageMaps of US States And Canadian Provinces Camped In


Federal Ownership Respectfully Declined
Present Vehicle
2015 F450 Platinum Crew Cab Long Bed DRW, White Platinum Tricoat, 6.7L Powerstroke Diesel, 225/70R/19.5 tires, Almost every option known to man (except a sunroof). Ford 27.5K Fifth Wheel Hitch; AirRide LoadLifter 5000 Air Suspension System with LoadController Single Air Compressor System; 60 gallon RDS Aluminum Auxiliary Tank; K&W 500 Series Chest Toolbox
"19.5s are chick magnets"
Former Vehicles
2016 Escape Titanium FWD, Shadow Black, Equipment Pkg 301A, Titanium Technology Package with HID Auto Headlamps, BLIS, Active Park Assist, 2.0L EcoBoost, Panoramic Vista Roof, SYNC3 with Navigation, 19" wheels
2012 Buick Verano Leather Group - Black Onyx - Sunroof, Navigation, Premium Exterior Package, WeatherTech DigitalFit liners (1st & 2nd Row), Wireless Rear View Camera.
User avatar
Charles
Super Moderator and Supreme Overlord of Web Darkness
 
Posts: 20222
E-C LEVEL 22
Joined: March 6th, 2008, 10:24 pm
Location: South Dakota
My nickname: Charles
My vehicle: 2015 F-450 Platinum DRW 4x4

Re: 2005 Ford Escape - Engine bucks only between 1500 - 2000

Postby bluto - February 19th, 2020, 3:15 pm

It sounds like you have replaced everything ignition, fuel and air related that would be a usual suspect. I have only a few long shot things to check. First you mentioned the theft light coming on. Have you tried using forscan to scan all the other modules for codes? It seems like you might find a code in the instrument cluster (IC) since it does the anti-theft stuff and syncs with the PCM to allow the engine to start.

The only other big thing that I can recommend is to check the PCM for signs of corrosion. And check all of the ground lugs under the hood for corrosion while you are at it. Both of those could cause un-explained issues.
Current: 2008 Escape XLT
Previous: 2002 Tribute ES V6
bluto
 
Posts: 363
E-C LEVEL 3
Joined: June 30th, 2012, 12:42 am
My vehicle: 2008 Escape XLT


Return to Problems And Solutions

Who is online

Users browsing this forum: Google [Bot] and 76 guests